iPhone 3GS constantly crashing/closing apps while running iOS 5

20111126-095031.jpg

Symptom:
iPhone 3GS blanks out and crashes open Application every few minutes (30 second to 2 minute intervals). Apps are still “open” in the Fast-Switch dock, but have been minimized by the crash. The crashes occur regardless of the App that is open, and prevails when Settings App is open.

Symptoms will not subside despite soft-reboots and hard-reboots.

Diagnosis:
This specific problem will occur if you have an iPhone 3GS running iOS 5 with an iCloud account linked and operational on the device.

Cause: iCloud. Specific cause undetermined; likely to be an unresolvable sync error.

Solution:

Connect your iPhone to your computer and back it up.

On your iPhone, go to Settings > Mail, Contacts, Calendars > iCloud > Delete Account.

Click “Delete” to confirm the removal of iCloud data from the iPhone.

When complete, add your iCloud account back by going to Settings > Mail, Contacts, Calendars > Add Account.

Disclaimer: I am not responsible for any direct or indirect data loss as a result of using this solution. Remember to back-up first.

Not Working: vBulletin “What’s New?” Search

So, putting together a new website I ran in to an obscure problem. vBulletin’s “What’s new?” button wasn’t working.

The cPanel was coming back with a similar error to this:

[notice] EACCELERATOR(#####): PHP crashed on opline 62 of method_exists() at /public_html/vb/search/criteria.php:844, referer: http://website.com/

You shouldn’t need to disable eAccelerator. Simply try this:

1. Open & Edit forum/vb/search/criteria.php
2. Search method_exist
3. Replace line:

if (method_exists($this->search_type, ‘get_display_name’))

with

if (is_object($this->search_type) && is_callable($this->search_type->get_display_name()))

4. Save & Enjoy!

DGN2000 Firmware Update Failure (Power LED flashes Red and Green)

What a fun night. Having tried updating my routers’ firmware and the update fail, I called NETGEAR who were less than helpful with their “We can’t do anything because it’s not under warranty” response.

Hopefully this may help someone else.

Scenario:

After Upgrading the firmware via wireless the routers’ power light constantly flashes red and green.

Solution:

  1. Download the initial release firmware for your region: http://kbserver.netgear.com/release_notes/d103335.asp
  2. Connect your router via Ethernet.
  3. Restart your router.
  4. Go to: http://www.routerlogin.com/basicsetting.htm (this is your router and is a local connection)
  5. Upload the firmware, and
  6. Follow On-screen instructions.

Your old settings should still remain.
You can now update to the latest firmware.